totally dating site uk - Garmin nuvi 660 updating bluetooth firmware

Here are some random tests for POIs near Toronto: Category Subcategory V4.60 V4.70 ------------- ------------------ -------- -------- Food All Food 3.56 3.59 Food Barbeque 6.83 5.81 Food Fast 3.59 3.65 Food German 73.18 70.96 Food Mexican 3.65 3.12 Bank/ATM 7.79 7.91 Shop Shop Ctr 6.75 6.66 Commun. I just wish they would detail exactly what they fix/improve.

I also expect they tweak little improvements/corrections throughout the unit.

--Nuvi 660 -- and not upgrading it or maps until Garmin fixes long-standing bugs/problems, and get maps to where they are much more current, AND corrected on a more timely basis when advised of mistakes.

go to the direct software update link: - Download: Nuvi 660 software update version 4.70 (4.86 MB) as of December 11, 2008 Thank you, thank you for sharing the info on holding power button down.

I just updated my Nuvi 660 from v.3.5 to v3.6 software and got the error message. Your procedure worked great,had the "System software missing" after a Webupdate_241.

Yesterday, while driving around town, suddenly the Nuvi 660 gave a message that it was downloading bluetooth update. I did note easy and successful pairing with my phone afterwards. I've only had that happen after I've run the webupdater (that had a BT update on it) and installed onto my 660, then the next time I booted up my GPSr in my car I have seen BT update in progress show on the screen.

There was a progress bar and after about 2 minutes it was done. I assumed that my device was just completing the BT update cycle.

But your procedure worked,took a good minute for the flicker and then the Pre-Boot message to disappear,then it started loading some Bluetooth update and then came back to the normal screen.

Thanks again, Siggy Your tip on holding the power button and waiting for the pre-boot sequence saved the day on my nuvi 350 when a software update to V6.0 failed and gave me the ill-fated "system software missing" error.

the changes are listed Changes made from version 4.60 to 4.70: Added support for one traffic provider Improved Points of Interest searching Updated to 4.7 yesterday evening and did a check on my 660 this morning.

So for me the traffic services didn't seem to work as well after the "upgrade." Anyways I decided to revert back to v. No problems encountered for the upgrade from 4.60 to 4.70 There is little difference in POI search times as claimed in "Improved Points of Interest searching" bullet in release notes. I would expect someone at Garmin monitor's POI Factory (as I consider Factory to be the best) and probably implement some discussions we have read about.

I contacted the local Garmin support rep and I was given the following sequence to recover from this condition: 1. KEEP HOLDING the power button down and the display will flicker, do this until the pre boot mode message disappears.

Comments are closed.